Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.

Log in or register to post/reply in the forum.

CS-GPS Clock Synchronization with CR1000

trashbk Jul 12, 2016 11:34 AM

Dear all,

I have a serious problem using the CS-GPS unit for clock synchronization. I went through the manual and its troubleshooting section several times, but the PPS signal just won't be received by the datalogger.

Let me describe in detail the situation, I hope somebody can help:

- the GPS is connected properly to the datalogger on COM4 (C7 and C8) as described in the manual

- the logger is a brand new CR1000 with OS 29.0, the GPS is a brand new GPS16-HVS from Campbell, so I expect it should be configured correctly

- COM4 is configured to 38400 baud fixed in DeviceConfig Utility

- in the logger program, ports are configured as input ports at program startup using PortsConfig() instruction

- I wrote a cr.1 program based on the example program in the manual.

- I get 8 satellites, I get the coordinates and altitude, fix_quality is 2. But gps_ready stays at 0 and pps is NAN.

I tried the steps in the Troubleshooting section of the GPS manual:

- connecting the GPS to a DB9 connector, white cable on Pin2, Black and Yellow on Pin 5 as indicated in the manual

- connecting this to the laptop on serial port and monitoring the output of the GPS:


According to the manual, these should be valid strings. I replaced my real coordinates with 9999 [ to avoid stalkers ;)  ].

- The 12th value in the GPSArray ( dt_since_gprmc) is constantly below 1s, as it should be.

- I tried changing the scan rate of the program, with 1 Hz, 100 mHz and 10 mHz. Faster scans reduce the dt_since_gprmc

  variable, but otherwise nothing changes.

Does anybody have an idea? That would be awesome.

aps Jul 12, 2016 01:15 PM

Are you using a A300 or SW12V interface between the logger and the GPS-16X as detailed on the website.   This did not need to be used but, due to an annoying design change by Garmin of the GPS16X, is now needed if you want to use the PPS signal with some of our older loggers which cannot read a lower voltage signal on the PPS output.  (The CR6 and CR300 can read the signal directly.)

If you do not need time synchronisation to the microsecond level, but a few tens of milliseconds are adequate, you do not have to use the PPS signal at all (in OS29 on).   This is signalled by entering the com port number as a negative value

trashbk Jul 12, 2016 01:44 PM

Dear Andrew,

this works. Thank you very much !!

dwind Jul 26, 2018 07:55 AM

Dear all,

I have a similiar problem.

I try to avoid the use of PPS signal by negating the COMport (tried -COM4 or -4) but I get a compile error.

any help please?

GaryTRoberts Jul 26, 2018 04:28 PM

dwind are you using the latest version of the OS for your device or an older one?

dwind Jul 30, 2018 09:48 AM

Dear Gary,

the CR1000 logger is brand new (S/N E11966).
OS Version:CR1000.Std3.2
RevBoard: 018.008

The thing is that I get the complie error in CrBasic: Build

PPS solved:

The PPS from Garmin is at 3V Level while the logger needs a 5V signal,
as checked with a pulse Generator.
As said above, a DC-DC converter would probably be OK


dwind Sep 6, 2018 01:05 PM

Dear all,

after getting an A300 DC-DC converter, and checking the pulse to be at 5V, still the clocks are not sychronized.
I also checked with another new data logger (E16748, OS std32) and still doesn't work.

Since the time synchronization to μs is not crucial , i tried again to negate the com port:


to avoid using the PPS signal, but still not worked.

any help please?

Nicolas Jun 12, 2021 03:42 PM


I'm trying to establish communication between a CR300 (new and last OS update) and a GPS (NMEA 0183 V3.01: GGA, GSA, GSV, RMC, VTG - 9600 bps) with this simple code.:


   Scan (1,Sec,0,0)     

   GPS (latitude_a,COMC1_RX,C2,LOCAL_TIME_OFFSET*3600,100,nmea_sentence(1),9600)    

As you can imagine, it doesn't work (tested with or without a PPS signal), I get NAN for all the frames coming from the GPS.

On the oscilloscope, I have a PPS signal of 3.3 V at 1 Hz as well as the data frame from the GPS (@ 5V). The data frame is approximately 910ms (always less than 1000ms).

The PPS parameter always return approx. 550 ms (that it is transmitted on C2, SE1, ...)), i don't understand.

On the terminal (7: COM RX), I have no data

I don't know what to test anymore. Please, do you have an idea ?

Thank you,


Log in or register to post/reply in the forum.