Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.


Log in or register to post/reply in the forum.

Task master failed to start


draffard Jun 12, 2013 12:31 PM

Hello

I use Loggernet admin 4.1 running as a service on windows 7.

I want to use task master to execute a batch file after a station event. The file is in the Campbell directory.

When i wan to execute the task, the task does not work and I can read the error message when I run the task: "failed to start the task".

I try the same task with a another computer with W7 on witch loggernet is not running as a service, and the task works well.

How can I use the task master with loggernet running as a service?

Thanks per advance

* Last updated by: draffard on 6/12/2013 @ 1:22 PM *


jtrauntvein Jun 13, 2013 03:28 PM

The most likely reason why the script can be run while logged in but not be able to run by LoggerNet running as a service is a difference in permissions. LoggerNet, when running as a service, by default will run in a local machine account with the imaginative name of "loggernet". Because this is a local machine account, the permissions given it may very well differ from those given your logon account. This can affect everything from LoggerNet's ability to access the script in the first place to the resources that the script can access while running.

This can be partly overcome by changing the account used by the LoggerNet service. You can do this by going into the "Computer Management" applet (right click on your "My Computer" icon and select "manage", expand the entry that states "Services and Applications", and select the entry that states "Services". In the resulting pane, you should be able to find the "CsiLoggerNet" service. If you right click on this and select properties, a dialogue will appear that has "Log On" in one of its tabs. You can use this table and dialogue to specify the account name under which LoggerNet will run.

I use the term "partly" above because even though LoggerNet has been configured to run under your chosen account, the drive mappings for this account will still not be available. This is due mainly to the way that windows is not designed. You can overcome this last by accessing network resources using UNC strings such as \\server\share\directory\file instead of relying on drive mappings.

Log in or register to post/reply in the forum.