Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.


Log in or register to post/reply in the forum.

RTMC Pro V5.0, data (MinRun, MaxRun, etc.,) not correctly display in first tab_id=0


Thein Nov 21, 2021 05:18 AM

Hi,

I have some issues with value display in first screen (tab_id=0) in one of my RTMC Project. It was coded to display "MaxRun", but it displays current latest value instead of maximum value since from start. However, it is fine with other tabs, e.g, tab_id=1, 2, 3, etc,. all displayed current latest recorded value.

Found out that, not only problem with MaxRun, but also cannot display MinRun, AvgRun, RunOverTime, RunOverTimeWithReset, etc,.

The things I would like to know is,
1) Is it a software bug?
2) Or is it actually cannot display like that?
3) Or did I make the mistake in RTMC project?

My RTMC Project can be download here.
The data file link to my RTMC project can be download here.
Web page can be viewed here. (At the bottom left of the main screen, the temperature values are coded to display as MaxRun, but it displayed current latest recorded temperature)

Thanks in advance.

Best regards,
Thein


Terri Nov 25, 2021 12:52 AM

Hi Thein,

I just noticed this today. I'll take a look at it and get back to it on the 29th. I was able to download the two files but not look at the link. Perhaps it can only be accessed from within your company.

Could you show a screen clip with an arrow pointing to, or a box around the part that gives you trouble so I will be sure to look at the correct thing? I'm seeing tabs called Home, A, B, C, and BT.


Thein Nov 29, 2021 03:07 AM

Hi Terri,

Thanks for your reply, really appreciated. You may view the link if needed. It is not confidential and that is why I shared the link to solve the issue in public.

Here is the screen clip you requested. Yes, there are five screens,
1) "Home": sort of dashboard (tab_id=0),
2) "A": charts and datatable of A location temperatures (tab_id=1)
3) "B": charts and datatable of B location temperatures (tab_id=2)
4) "C": charts and datatable of C location temperatures (tab_id=3)
5) "BT": Logger's battery&temperature status wrt ambient (tab_id-4)

To recall the issue, the "MaxRun" data are not correctly display in Home tab (tan_id=0), not only "MaxRun" but also "MinRun", "MaxOverTime", "MaxOverTimeWithReset", etc,. But in other tabs, these are correctly displayed.

Thanks in advance. I do have some other issues with other RTMC projects, not to confuse, I will ask later.

Best regards,
Thein

Log in or register to post/reply in the forum.