Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.


Log in or register to post/reply in the forum.

SendVariables isnt working after OS update CR300


asolver Oct 13, 2020 02:37 PM

Hi,

We have some routines to send data to RS232 port.

When SerialOut and SendVariables sentences are used together on CR300 OS v5 these work correctly, but after the update (OS v10) these do not work.

Here I copy part of the program:

' ===========================================================================      
If IfTime (0,1,Min) Then ' ---- Envíos cada 1 minuto ---------------------       
SerialOpen (ComRS232,9600,0,0,50)     
    SerialOut (ComRS232,"$MSM289 "+"1/"+DatosAIS.WS_knots_AVG(1,1)+" 3/"+DatosAIS.WinDir(1,1)+" 11/"+DatosAIS.Lvl_m_AVG(1,1),"",0,0) 
    SerialOut (ComRS232,CHR(10)+CHR(13),"",0,0)
    SerialClose (COMRS232)     
EndIf 
If IfTime (0,5,Min) Then
       SendVariables (Result,ComRS232,0,4094,0000,0,"DatosMareog","Callback",WinDir,0)     
EndIf
'============================================================================


The result in the terminal is:

CR300 OS v5: 

½Ÿþ[00]A¦[08]½½Ÿþ[00]A¦[08]½½Ÿþ[00]A¦[08]½½¯þpA[1F]þ[00]A[1B]y[00][00]DatosMareog[00]	Callback[00][00][00]Þb½$MSM289 1/NAN 3/NAN 11/NAN
$MSM289 1/NAN 3/NAN 11/NAN
$MSM289 1/NAN 3/NAN 11/NAN
$MSM289 1/NAN 3/NAN 11/NAN ...

 CR300 OS v10

$MSM289 1/NAN 3/NAN 11/NAN
$MSM289 1/NAN 3/NAN 11/NAN
$MSM289 1/NAN 3/NAN 11/NAN
$MSM289 1/NAN 3/NAN 11/NAN
$MSM289 1/NAN 3/NAN 11/NAN
$MSM289 1/NAN 3/NAN 11/NAN
...

Best regards.

Alexander 

Log in or register to post/reply in the forum.