Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.


Log in or register to post/reply in the forum.

LNDB isn't automatically inserting data from .dat files into database


Minh T. Jun 13, 2020 07:02 PM

According to this page:

LNDB is a new LoggerNet client application that copies data from the LoggerNet server's data cache into a database. LoggerNet's data cache is updated by enabling scheduled data collection with the dataloggers in the network. The LNDB engine then populates the database with the data collected from the dataloggers.

We've Enabled Communication with a Station, have Enabled Call-Back, but disabled Scheduled Collection (our remote station connects to LN (as written in the firmware) and sends records it has collected). The collected data should be in LN server's data cache because we see the collected data in the .dat files.

Though present in the .dat files, the collected records weren't automatically inserted into the database.

We use Microsoft SQL Server and have verified the correct DB login credentials and table-mappings -- this collection setup has worked for us in the past but has suddenly stopped working. We can use LNDB's Data Import tool to import data from .dat files but we need the data imported automatically.

Again, LNDB has done this for us in the past and it's strange that it suddenly stopped working. We could get around this by writing an application which reads from .dat files and inserts whatever it finds (that aren't duplicates) into the database but perhaps it's a LN configuration issue.

Do you have any advice for us?


JDavis Jun 15, 2020 01:43 PM

It shouldn't be necessary, but before I saw a customer resolve call back issues by enabling scheduled collection. Loggernet would not be able to call the station on schedule, but it fixed an issue for when the datalogger was calling in.

Maybe give a try with a schedule set to when you know Loggernet will fail to collect. Do check the box in settings to stay on schedule.

Log in or register to post/reply in the forum.