Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.


Log in or register to post/reply in the forum.

SDI-12 skipped scans when data retrieved


BartZaw May 3, 2020 04:50 AM

Hello everyone,

I have a problem…

We are using a CR1000 to record 30 SDI-12 HydraProbe (Stevens) soil water content measurements. The main scans interval is 1 min and to retrieve the data from all Hydraprobes it takes something like 30sec. Data table records all measurements as “samples” (interval 1 min. then). So, it works fine. The problem starts when I am connecting the CR1000 and retrieving data with a LoggerNet (connected to RS232 port by a cable). When I retrieve the data, always 10 scans are skipped… Independently how many buffers (into “scan” instruction) I am using. We cannot slow down the scans nor data retrieval periodicity. My question is: is it a way to get ride to the skipped scans without split our station with two or more loggers? If you have any clues, please share it. Thank you for any help.


JDavis May 4, 2020 10:12 AM

Is the program compiled in pipeline mode or sequential mode? If it is in sequential mode, getting it to run in pipeline mode might solve the issue.


BartZaw May 4, 2020 10:21 AM

Thank you for your help. Is in pipline mode already.


h20bug May 4, 2020 12:17 PM

Do you have your SDI12Recorder instructions in the main section of the program or in a SlowSequence Scan?  If SDI12Recorder is in the main program, you might try moving it to a SlowSequence.  


BartZaw May 5, 2020 12:18 AM

Hello,

 

Main scans are every one minute (cannot change it) and all data have to be recorded at that frequency (cannot change it). Record all data take more than 30s (32s to be exact), so it is not really possible to have a slow sequence. But, trying about everything from my home (we are confined in France and the logger is outside with a VPN access) I have solved the problem recording data file as TOB3 not TOA5 neither TOB1. When working with TOB3 files, there is no more skipped scans… It sounds like an internal memory management problem…

But problem solved so I can take some rest 😊

Thanks for your help. I apreciate it.

Log in or register to post/reply in the forum.