Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.


Log in or register to post/reply in the forum.

How to configure CR300 as ModBus slave?


alexandrecf80 Aug 23, 2019 08:34 AM

Hi, 

How do I configure the CR300 as a ModBUs slave device for using with direct connection and RS-232 interface? I'll have an external application as a ModBus master.

I'm not finding this option in the Short Cut application (Control item) as in some tutorials for the CR1000 device. Do I need a special OS version? I'm using OS 6.01.

Best regards,

Alexandre


GaryTRoberts Aug 26, 2019 09:37 AM

Yes. You need a newer version of the logger operating system for the CR1000. The current/latest released version is 32.03. The ModusSlave() instruction will get you what you are looking for.


alexandrecf80 Aug 26, 2019 02:21 PM

Hi Gary.

Thanks for your reply.

I'm using the CR300, not the CR1000.  As seen in https://www.campbellsci.com/downloads/cr300-series-os, the last version of the OS for CR300 is 9.02.

It's the same for CR300? The ModbusSlave() instruction is available in version 9.02?

Best regards,

Alexandre


GaryTRoberts Aug 27, 2019 03:02 PM

Yes, ModBusSlave() is in OS 09.02. It has been in the CR300 OS for a long time. Since at least version 3.0. You will have to program it by hand. ModBusSlave() is not in ShortCut for the CR300.


alexandrecf80 Aug 31, 2019 02:31 PM

Hi, Gary.

I successfully programmed the Modbus Slave mode by hand in CR300 using CRBasic Editor and the application note "Using Campbell Scientific Dataloggers as Modbus Slave Devices in a SCADA Network".

Thanks for your help!

Log in or register to post/reply in the forum.