Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.


Log in or register to post/reply in the forum.

CR1000x OS update failed


Daniwenz Aug 21, 2019 06:58 AM

Greetings,

I have a problem regarding the update of CR1000X OS.

Yesterday, I've tried to update the OS from version 2.00 to 3.02 with Device Config.

I connected usb cable to PC, provided 12V on regular power pins, connected to logger via device configuration utility, on 'Manage OS' tab, then I clicked on update.. After a while, it ended with a error message but I could see it updated to 3.02 on the same tab (Manage OS)

After that, datalogger started rebooting every 10~15 seconds, so sometimes I can connect to it and even see some information about it (Station Name, Serial Number, OS Version...)

I dont use Run at startup on my application.

I dont need to recover data/application inside it, so if there's a way of sending the OS again, because my guess is some firmware file corruption / flash memory wiped ??.

Tried to send it through 'Send OS' tab (before connecting), changing baudrates (9600, 115200), with no success, he starts to download but after 10~15 seconds it shuts down and turn on again.

Thanks!


DAM Aug 21, 2019 10:38 AM

 1) Remove USB cable and power from the CR1000X

2) Press and hold the card eject button.

3) while pressing the button connect the usb cable

4) keep holding the button until the power LED begins flashing (about 5 Sec).

5) Send the OS again via DevConfig Send OS tab (before connecting).

You must begin sending the OS within 40 seconds of getting the LED flashing or this mode will timeout.


Daniwenz Aug 21, 2019 11:18 AM

Amazing, it worked!

Thanks for helping...

Log in or register to post/reply in the forum.