Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.


Log in or register to post/reply in the forum.

Enable http website for datalogger


matttt Mar 5, 2018 12:25 PM

I am trying to connect to several CR1000 dataloggers with the python library PyCampbell. For one of the dataloggers I am able to connect to the logger and retrieve data. For the other datalogger I am unbable to do this.

I looked further into the settings page for each of the dataloggers to try and see what the difference betweens the two setups is. It appears that one datalogger ( that is not connecting through pyCampbell) is running CR1000.Std.22. The other (which is connecting through pyCambell) is running CR1000.Std.30.1 . The logger that I can connect to successfuly has an option under Connect > Settings Editor > Ethernet for Ethernet Power always on. When I type in the IP adress for the logger which I can successfully connect to in pyCampbell like this in a web browser > http://<ip-address> , a webpage for the datalogger loads. This does not happen for the datalogger I am having troubles connecting to. I am able to connec to both dataloggers through loggernet connect.

Has anyone else had similar issues? How can I enable an http side for a datalogger? 

Thank you,

Matan


JDavis Mar 5, 2018 12:34 PM

OS version 22 did not have the HTTP server feature in the datalogger. You need to update that datalogger.

https://www.campbellsci.com/videos/sending-an-os-to-a-local-datalogger-part-1


bilal Jan 15, 2019 05:08 PM

@Matttt, Could you please share how did you able to conect to CR1000? I am facing problems with python library PyCampbell. After installing the library, when i try to import CR1000, i keep getting error, AttributeError: 'OutStream' object has no attribute 'buffer'. I could not find a solution to this error so far.

Your help would be really appreciated. 

thanks


bengelsen23 Feb 6, 2020 09:26 AM

@bilal, I am facing the same exact problem with the PyCampbell library.I am getting the same error and I can't find a solution anywhere. Have you been able to resolve the solution?


Makada Nov 5, 2020 11:49 PM

I see the same error (using serial com setting in pycampbellcr1000) must be an solution somewhere ...?

Ive tried a different pc, but get the same error.

https://pycampbellcr1000.readthedocs.io/en/latest/

Here the actual error in python: 

Traceback (most recent call last):
  File "C:\Users\Makada\Desktop\cr1000 modbus.py", line 1, in 
    from pycampbellcr1000 import CR1000
  File "C:\Users\Makada\AppData\Local\Programs\Python\Python38\lib\site-packages\pycampbellcr1000\__init__.py", line 13, in 
    from .logger import LOGGER, active_logger
  File "C:\Users\Makada\AppData\Local\Programs\Python\Python38\lib\site-packages\pycampbellcr1000\logger.py", line 14, in 
    from .compat import NullHandler
  File "C:\Users\Makada\AppData\Local\Programs\Python\Python38\lib\site-packages\pycampbellcr1000\compat.py", line 94, in 
    stdout = sys.stdout.buffer
AttributeError: 'StdOutputFile' object has no attribute 'buffer'
>>> 

 

Log in or register to post/reply in the forum.