Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.


Log in or register to post/reply in the forum.

Changing Station Name


MPPMC Dec 13, 2011 04:48 AM

We've recently added a CFM100 CF Module to one of our CR1000s as a memory back up. Using a basic program for testing purposes that simply uses a CardOut instruction and a Sample of a simple counter, an error is returned when sent to the logger:

[Compile Results]

CPU:Dev - CardOut.CR1 -- Compiled in SequentialMode

Error opening file CRD:\E2524/PMC1135.Test.dat! errno: 7

OS Version: CR1000.Std.21

I suspect this is because the station name is 'E2524/PMC1135' which confuses the logger as it thinks the / is part of the address path to the file it just attempted to write (The DataTable is called 'Test'). The problem is that I can't change the station name back to something simple to find out.

When connected with Dev Config I can change every other setting except for the Station Name:

Under [Deployment > Datalogger] it disconnects with the message 'Settings save failed and the device session has ended'.

Under [Settings Editor] I get the message 'Commit failed: Unrecognised error condition'.

Using the Connect Screen and updating the Station Name via the Status Table, the field just reverts back to E2524/PMC1135 whenever I type over it.

Any suggestions? Is there a way to do a complete factory reset? I have tried the Dev Config 'Factory Defaults' but it fails to save with the same 'Settings save failed and the device session has ended' error.


GTProdMgr Dec 13, 2011 09:52 AM

You definitely do not want to have a station name with a slash in it, and I agree that the problems you see are being caused by that slash.

Try running this little program on your logger:

BeginProg
SetStatus("StationName","Default")
EndProg

You can put anything you want for your station
name instead of "Default", as long as it doesn't
have a slash or other invalid character.

I think this should work for you.


Dana Dec 13, 2011 11:17 AM

If you can not/do not want to send the SetStatus program to the datalogger, you can change the station name by editing it directly in the Status table.

This can be done from LoggerNet's Connect window (Table Monitor or Numeric Display -- right click the value to get a "Edit/Modify" dialog box, or double-click and type in the new name). You can also edit the Status table field using PakBus Graph (select datalogger, right click, and choose edit settings).

Regards,
Dana W.


MPPMC Dec 15, 2011 01:27 AM

Got it changed thanks! Just modified the value in the status table via connect screen. Had been trying to do that by just double clicking and typing a new value followed by return. Didn't realise there was a difference in doing it via the right click > modify value. Anyway, thanks for the help!


dberdes Mar 24, 2021 11:19 AM

I am trying to change the "StationName" Setting within a CR3000 program:

BeginProg

     SetSetting ("StationName", "APG_VDF_CR3000")

EndProg

The CR3000 program compiles fine and loads fine but the StationName field in the Settings and Status tables remain the same default setting.

I have also attempted SetStatus ("StationName", "APG_VDF_CR3000") to no avail.

Any suggestions?


pokeeffe Mar 24, 2021 11:49 AM

Check the CRBasic help for `StationName()` for more details


dberdes Mar 25, 2021 11:36 AM

@pokeeffe Your suggestion worked.  Thank you!  However, I still would like to know why the "SetSetting" or "SetStatus" instruction did not work.

Log in or register to post/reply in the forum.